What’s Vulnerable › Vulnerabilities
CVE-2025-36047: IBM WebSphere Application Server Liberty denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-770
Description
IBM WebSphere Application Server Liberty 18.0.0.2 through 25.0.0.8 is vulnerable to a denial of service, caused by sending a specially-crafted request. A remote attacker could exploit this vulnerability to cause the server to consume memory resources.
Affected products
- IBM WebSphere Application Server: from 18.0.0.2 before 25.0.0.9 — fixed in 25.0.0.9
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 25.0.0.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-36047 or the next vulnerability affects your stack