What’s Vulnerable › Vulnerabilities
CVE-2025-36097: IBM WebSphere Application Server denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-16 · updated 2026-06-17
- Weakness: CWE-121
Description
IBM WebSphere Application Server 9.0 and WebSphere Application Server Liberty 17.0.0.3 through 25.0.0.7 are vulnerable to a denial of service, caused by a stack-based overflow. An attacker can send a specially crafted request that cause the server to consume excessive memory resources.
Affected products
- IBM WebSphere Application Server: from 9.0.0.0 before 9.0.5.24; from 17.0.0.3 before 25.0.0.8 — fixed in 25.0.0.8, 9.0.5.24
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 25.0.0.8, 9.0.5.24. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-36097 or the next vulnerability affects your stack