What’s Vulnerable › Vulnerabilities

CVE-2025-36100: IBM MQ information disclosure

Description

IBM MQ LTS 9.1.0.0 through 9.1.0.29, 9.2.0.0 through 9.2.0.36, 9.3.0.0 through 9.3.0.30 and 9.4.0.0 through 9.4.0.12 and IBM MQ CD 9.3.0.0 through 9.3.5.1 and 9.4.0.0 through 9.4.3.0  Java and JMS stores a password in client configuration files when trace is enabled which can be read by a local user.

Affected products

How to fix

Upgrade to a fixed version: IBM MQ 9.1.0.31, 9.2.0.37, 9.3.0.31, 9.4.0.15. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-36100 or the next vulnerability affects your stack