What’s Vulnerable › Vulnerabilities
CVE-2025-36126: IBM Cognos Analytics is affected by Cross-site scripting.
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-26 · updated 2026-07-24
- Weakness: CWE-79
Description
IBM Cognos Analytics 11.2.0, 12.0, and 12.1.0 and IBM Cognos Transformer 12.0, 11.2.4, and 12.1.0 is vulnerable to stored cross-site scripting (XSS) in Cognos Adminstration. This vulnerability allows a privileged user to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.
Affected products
- IBM Cognos Analytics: from 12.1.0 before 12.1.2; 11.2, 11.2.0, 11.2.1, 11.2.2, 11.2.3, 11.2.4 (+22) — fixed in 12.1.2
- IBM Cognos Transformer: 11.2.4, 12.0, 12.1.0
How to fix
Upgrade to a fixed version: IBM Cognos Analytics 12.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-36126 or the next vulnerability affects your stack