What’s Vulnerable › Vulnerabilities
CVE-2025-36137: IBM Sterling Connect:Direct for UNIX command execution
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-30 · updated 2026-10-07
- Weakness: CWE-250
Description
IBM Sterling Connect Direct for Unix 6.2.0.7 through 6.2.0.9 iFix004, 6.4.0.0 through 6.4.0.2 iFix001, and 6.3.0.2 through 6.3.0.5 iFix002 incorrectly assigns permissions for maintenance tasks to Control Center Director (CCD) users that could allow a privileged user to escalate their privileges further due to unnecessary privilege assignment for post update scripts.
Affected products
- IBM Sterling Connect:Direct for UNIX: from 6.2.0.7 before 6.2.0.9; from 6.3.0.2 before 6.3.0.5; from 6.4.0.0 before 6.4.0.2; 6.2.0.9, 6.2.0.9-ifix004, 6.3.0.5, 6.3.0.5-ifix002, 6.4.0.2, 6.4.0.2-ifix001 — fixed in 6.2.0.9, 6.3.0.5, 6.4.0.2
How to fix
Upgrade to a fixed version: IBM Sterling Connect:Direct for UNIX 6.2.0.9, 6.3.0.5, 6.4.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-36137 or the next vulnerability affects your stack