What’s Vulnerable › Vulnerabilities
CVE-2025-36148: IBM Financial Transaction Manager for SWIFT Services for Multiplatforms is vulnerable to cross-site scripting.
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-26 · updated 2026-07-24
- Weakness: CWE-79
Description
IBM Financial Transaction Manager for SWIFT Services for Multiplatforms 3.2.4.0 through 3.2.4.15 IBM Financial Transaction Manager SWIFT is vulnerable to cross-site scripting. This vulnerability allows an unauthenticated attacker to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.
Affected products
- IBM Financial Transaction Manager for SWIFT Services for Multiplatforms: from 3.2.4.0 before 3.2.4.16 — fixed in 3.2.4.16
How to fix
Upgrade to a fixed version: IBM Financial Transaction Manager for SWIFT Services for Multiplatforms 3.2.4.16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-36148 or the next vulnerability affects your stack