What’s Vulnerable › Vulnerabilities
CVE-2025-3627: Moodle: partial data exposure in moodle before completing multi-factor authentication
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-25 · updated 2026-06-17
- Weakness: CWE-287
Description
A security vulnerability was discovered in Moodle that allows some users to access sensitive information about other students before they finish verifying their identities using two-factor authentication (2FA).
Affected products
- Moodle: from 4.3.0 before 4.3.12; from 4.4.0 before 4.4.8; from 4.5.0 before 4.5.4 — fixed in 4.3.12, 4.4.8, 4.5.4
How to fix
Upgrade to a fixed version: Moodle 4.3.12, 4.4.8, 4.5.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-3627
- https://bugzilla.redhat.com/show_bug.cgi?id=2359692
Get alerted when CVE-2025-3627 or the next vulnerability affects your stack