What’s Vulnerable › Vulnerabilities
CVE-2025-3631: IBM MQ denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-11 · updated 2026-06-17
- Weakness: CWE-416
Description
An IBM MQ 9.3 and 9.4 Client connecting to an MQ Queue Manager can cause a SIGSEGV in the AMQRMPPA channel process terminating it.
Affected products
- IBM MQ Appliance: from 9.3.2 through 9.3.5.2; from 9.4.0.0 before 9.4.0.12; from 9.4.0.0 before 9.4.3; from 9.4.1.0 before 9.4.3.0 — fixed in 9.4.0.12, 9.4.3, 9.4.3.0
How to fix
Upgrade to a fixed version: IBM MQ Appliance 9.4.0.12, 9.4.3, 9.4.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3631 or the next vulnerability affects your stack