What’s Vulnerable › Vulnerabilities
CVE-2025-3632: IBM 4769 Developers Toolkit denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-12 · updated 2026-06-17
- Weakness: CWE-789
Description
IBM 4769 Developers Toolkit 7.0.0 through 7.5.52 could allow a remote attacker to cause a denial of service in the Hardware Security Module (HSM) due to improper memory allocation of an excessive size.
Affected products
- IBM 4769 Developers Toolkit: from 7.0.0 before 7.5.62 — fixed in 7.5.62
How to fix
Upgrade to a fixed version: IBM 4769 Developers Toolkit 7.5.62. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3632 or the next vulnerability affects your stack