What’s Vulnerable › Vulnerabilities
CVE-2025-3633: IBM Cognos Analytics is affected by multiple security vulnerabilities
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-10-14
- Weakness: CWE-79
Description
IBM Cognos Analytics 11.2.0, 11.2.4, 12.0, and 12.1.0 and IBM Cognos Transformer 11.2.4, 12.0, and 12.1.0 are vulnerable to cross-site scripting (XSS). This vulnerability allows a remote attacker to inject arbitrary JavaScript code into the web user interface, which may alter the intended functionality and could lead to the disclosure of credentials within a trusted session.
Affected products
- IBM Cognos Analytics: from 11.2.0 before 11.2.4; from 12.0.0 before 12.0.4; from 12.1.0 before 12.1.2; 11.2.4, 11.2.4-fixpack1, 11.2.4-fixpack2, 11.2.4-fixpack3, 11.2.4-fixpack4, 11.2.4-fixpack5 (+9) — fixed in 11.2.4, 12.0.4, 12.1.2
- IBM Cognos Transformer: 11.2.4, 12.0, 12.1.0
How to fix
Upgrade to a fixed version: IBM Cognos Analytics 11.2.4, 12.0.4, 12.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3633 or the next vulnerability affects your stack