What’s Vulnerable › Vulnerabilities

CVE-2025-36360: IBM DevOps Deploy / IBM UrbanCode Deploy (UCD) is susceptible to an Insufficient Session Expiration vulnerability

Description

IBM UCD - IBM UrbanCode Deploy 7.1 through 7.1.2.27, 7.2 through 7.2.3.20, and 7.3 through 7.3.2.15 and IBM UCD - IBM DevOps Deploy 8.0 through 8.0.1.10, and 8.1 through 8.1.2.3 is susceptible to a race condition in http-session client-IP binding enforcement which may allow a session to be briefly reused from a new IP address before it is invalidated, potentially enabling unauthorized access under certain network conditions.

Affected products

How to fix

Upgrade to a fixed version: IBM DevOps Deploy 8.0.1.11, 8.1.2.4; IBM UrbanCode Deploy 7.1.2.28, 7.2.3.21, 7.3.2.16. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-36360 or the next vulnerability affects your stack