What’s Vulnerable › Vulnerabilities
CVE-2025-3637: Moodle: csrf token exposure via url in moodle mod_data module
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-25 · updated 2026-06-17
- Weakness: CWE-598
Description
A security vulnerability was found in Moodle where confidential information that prevents cross-site request forgery (CSRF) attacks was shared publicly through the site's URL. This vulnerability occurred specifically on two types of pages within the mod_data module: edit and delete pages.
Affected products
- Moodle: before 4.3.12; from 4.4.0 before 4.4.8; from 4.5.0 before 4.5.4 — fixed in 4.3.12, 4.4.8, 4.5.4
How to fix
Upgrade to a fixed version: Moodle 4.3.12, 4.4.8, 4.5.4. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-65356
- https://access.redhat.com/security/cve/CVE-2025-3637
- https://bugzilla.redhat.com/show_bug.cgi?id=2359727
Get alerted when CVE-2025-3637 or the next vulnerability affects your stack