What’s Vulnerable › Vulnerabilities
CVE-2025-36372: IBM® Db2® could disclose sensitive information to an authenticated user from the monitoring and event tables
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-09-29
- Weakness: CWE-538
Description
IBM Db2 11.5.0 through 11.5.9, and 12.1.0 through 12.1.4 for Linux, UNIX and Windows (includes Db2 Connect Server) could disclose sensitive information to an authenticated user from the monitoring and event tables.
Affected products
- IBM Db2 for Linux, UNIX and Windows: from 11.5.0 before 11.5.9; from 12.1.0 through 12.1.4 — fixed in 11.5.9
How to fix
Upgrade to a fixed version: IBM Db2 for Linux, UNIX and Windows 11.5.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-36372 or the next vulnerability affects your stack