What’s Vulnerable › Vulnerabilities

CVE-2025-36375: IBM DataPower Gateway vulnerable to CSRF

Description

IBM DataPower Gateway 10.6CD 10.6.1.0 through 10.6.5.0 and IBM DataPower Gateway 10.5.0 10.5.0.0 through 10.5.0.20 and IBM DataPower Gateway 10.6.0 10.6.0.0 through 10.6.0.8 IBM DataPower Gateway is vulnerable to cross-site request forgery which could allow an attacker to execute malicious and unauthorized actions transmitted from a user that the website trusts.

Affected products

How to fix

Upgrade to a fixed version: IBM DataPower Gateway 11.0.0 10.5.0.21, 10.6.0.9, 10.6.6.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-36375 or the next vulnerability affects your stack