What’s Vulnerable › Vulnerabilities
CVE-2025-3640: Moodle: idor in web service allows users enrolled in a course to access some details of other users
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-25 · updated 2026-06-17
- Weakness: CWE-639
Description
A flaw was found in Moodle. Insufficient capability checks made it possible for a user enrolled in a course to access some details, such as the full name and profile image URL, of other users they did not have permission to access.
Affected products
- Moodle: before 4.1.18; from 4.3.0 before 4.3.12; from 4.4.0 before 4.4.8; from 4.5.0 before 4.5.4 — fixed in 4.1.18, 4.3.12, 4.4.8, 4.5.4
How to fix
Upgrade to a fixed version: Moodle 4.1.18, 4.3.12, 4.4.8, 4.5.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-3640
- https://bugzilla.redhat.com/show_bug.cgi?id=2359734
- https://moodle.org/mod/forum/discuss.php?d=467601
Get alerted when CVE-2025-3640 or the next vulnerability affects your stack