What’s Vulnerable › Vulnerabilities
CVE-2025-3642: Moodle: authenticated remote code execution risk in the moodle lms equella repository
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-25 · updated 2026-06-17
- Weakness: CWE-94
Description
A flaw was found in Moodle. A remote code execution risk was identified in the Moodle LMS EQUELLA repository. By default, this was only available to teachers and managers on sites with the EQUELLA repository enabled.
Affected products
- Moodle: before 4.1.18; from 4.3.0 before 4.3.12; from 4.4.0 before 4.4.8; from 4.5.0 before 4.5.4 — fixed in 4.1.18, 4.3.12, 4.4.8, 4.5.4
How to fix
Upgrade to a fixed version: Moodle 4.1.18, 4.3.12, 4.4.8, 4.5.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-3642
- https://bugzilla.redhat.com/show_bug.cgi?id=2359738
- https://moodle.org/mod/forum/discuss.php?d=467603
Get alerted when CVE-2025-3642 or the next vulnerability affects your stack