What’s Vulnerable › Vulnerabilities

CVE-2025-36530: Import Path Traversal Enables Unauthorized Unsigned Plugin Installation

Description

Mattermost versions 10.9.x <= 10.9.1, 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate file paths during plugin import operations which allows restricted admin users to install unauthorized custom plugins via path traversal in the import functionality, bypassing plugin signature enforcement and marketplace restrictions.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.5.9, 10.8.4, 10.9.2, 9.11.18. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-36530 or the next vulnerability affects your stack