What’s Vulnerable › Vulnerabilities
CVE-2025-36579
- Severity: medium (CVSS 5.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-16 · updated 2026-06-17
- Weakness: CWE-640
Description
Dell Client Platform BIOS contains a Weak Password Recovery Mechanism vulnerability. An unauthenticated attacker with physical access to the system could potentially exploit this vulnerability, leading to unauthorized access.
Affected products
- Dell Alienware 16 Area-51 AA16250: before 1.9.0 — fixed in 1.9.0
- Dell Alienware 16X Aurora AC16251: before 1.8.1 — fixed in 1.8.1
- Dell Alienware 18 Area-51 AA18250: before 1.9.0 — fixed in 1.9.0
- Dell Alienware Area-51 AAT225: before 1.11.0 — fixed in 1.11.0
- Dell Alienware Aurora ACT1250: before 1.10.0 — fixed in 1.10.0
- Dell Alienware m15 R6: before 1.42.0 — fixed in 1.42.0
- Dell Alienware m15 R7: before 1.37.0 — fixed in 1.37.0
- Dell Alienware m16 R1: before 1.32.0 — fixed in 1.32.0
- Dell Alienware m16 R2: before 1.18.0 — fixed in 1.18.0
- Dell Alienware m18 R1: before 1.32.0 — fixed in 1.32.0
- Dell Alienware M18 R2: before 1.20.0 — fixed in 1.20.0
- Dell Alienware x14 R2: before 1.30.1 — fixed in 1.30.1
- Dell Alienware x16 R1: before 1.30.1 — fixed in 1.30.1
- Dell Alienware X16 R2: before 1.18.1 — fixed in 1.18.1
- Dell ChengMing 3900: before 1.37.0 — fixed in 1.37.0
- Dell ChengMing 3910/3911: before 1.32.0 — fixed in 1.32.0
- Dell ChengMing 3990: before 1.35.1 — fixed in 1.35.1
- Dell ChengMing 3991: before 1.35.1 — fixed in 1.35.1
- Dell 14 DC14250: before 1.4.0 — fixed in 1.4.0
- Dell 14 Premium DA14250: before 1.5.1 — fixed in 1.5.1
- Dell 15 DC15250: before 1.6.0 — fixed in 1.6.0
- Dell 16 DC16250: before 1.7.0 — fixed in 1.7.0
- Dell 16 DC16251: before 1.7.0 — fixed in 1.7.0
- Dell 16 Premium DA16250: before 1.7.0 — fixed in 1.7.0
- Dell G15 5510: before 1.38.0 — fixed in 1.38.0
- Dell G15 5511: before 1.41.0 — fixed in 1.41.0
- Dell G15 5520: before 1.38.0 — fixed in 1.38.0
- Dell G15 5530: before 1.30.0 — fixed in 1.30.0
- Dell G16 7620: before 1.38.0 — fixed in 1.38.0
- Dell G16 7630: before 1.30.0 — fixed in 1.30.0
How to fix
Upgrade to a fixed version: Dell Alienware 16 Area-51 AA16250 1.9.0; Dell Alienware 16X Aurora AC16251 1.8.1; Dell Alienware 18 Area-51 AA18250 1.9.0; Dell Alienware Area-51 AAT225 1.11.0; Dell Alienware Aurora ACT1250 1.10.0; Dell Alienware m15 R6 1.42.0; Dell Alienware m15 R7 1.37.0; Dell Alienware m16 R1 1.32.0; Dell Alienware m16 R2 1.18.0; Dell Alienware m18 R1 1.32.0; Dell Alienware M18 R2 1.20.0; Dell Alienware x14 R2 1.30.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-36579 or the next vulnerability affects your stack