What’s Vulnerable › Vulnerabilities
CVE-2025-36591
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-10-14
- Weakness: CWE-327
Description
Dell ECS versions 3.8.1.0 through 3.8.1.7, and Dell ObjectScale versions prior to 4.4.0.0, contains an Use of a Broken or Risky Cryptographic Algorithm vulnerability. A high privileged attacker with local access could potentially exploit this vulnerability, leading to Information exposure.
Affected products
- Dell Elastic Cloud Storage (ECS): before Version 4.4.0.0 or later — fixed in Version 4.4.0.0 or later
How to fix
Upgrade to a fixed version: Dell Elastic Cloud Storage (ECS) Version 4.4.0.0 or later. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-36591 or the next vulnerability affects your stack