What’s Vulnerable › Vulnerabilities
CVE-2025-37104: HPE Telco Service Orchestrator Software, Authenticated SQL Injection
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-16 · updated 2026-06-17
- Weakness: CWE-89
Description
A security vulnerability has been identified in HPE Telco Service Orchestrator software. The vulnerability could allow authenticated clients to to perform a SQL Injection attack when sending a service request, and potentially exfiltrate the database's vendor name to unauthorized authenticated clients.
Affected products
- Hewlett Packard Enterprise (HPE) HPE Telco Service Orchestrator: before 5.2.1 — fixed in 5.2.1
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) HPE Telco Service Orchestrator 5.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-37104 or the next vulnerability affects your stack