What’s Vulnerable › Vulnerabilities
CVE-2025-37157: Authenticated Command Injection allows Unauthorized Command Execution in AOS-CX
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-18 · updated 2026-10-18
- Weakness: CWE-94
Description
A command injection vulnerability exists in the AOS-CX Operating System. Successful exploitation could allow an authenticated remote attacker to conduct a Remote Code Execution (RCE) on the affected system.
Affected products
- Hewlett Packard Enterprise (HPE) AOS-CX: from 10.10.0000 before 10.10.1170; from 10.13.0000 before 10.13.1101; from 10.14.0000 before 10.14.1060; from 10.15.0000 before 10.15.1030; from 10.16.0000 before 10.16.1001 — fixed in 10.10.1170, 10.13.1101, 10.14.1060, 10.15.1030, 10.16.1001
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) AOS-CX 10.10.1170, 10.13.1101, 10.14.1060, 10.15.1030. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-37157 or the next vulnerability affects your stack