What’s Vulnerable › Vulnerabilities
CVE-2025-37169: Stack Overflow Vulnerability in AOS-10 Web-Based Management Interface
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-06-17
- Weakness: CWE-787
Description
A stack overflow vulnerability exists in the AOS-10 web-based management interface of a Mobility Gateway. Successful exploitation could allow an authenticated malicious actor to execute arbitrary code as a privileged user on the underlying operating system.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 10.3.0.0 before 10.4.1.10; from 10.5.0.0 before 10.7.2.2 — fixed in 10.4.1.10, 10.7.2.2
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.4.1.10, 10.7.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-37169 or the next vulnerability affects your stack