What’s Vulnerable › Vulnerabilities
CVE-2025-3717: Incorrect oauth passthrough in Grafana Snowflake Datasource
- Severity: low (CVSS 2.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-11 · updated 2026-10-18
- Weakness: CWE-653
Description
When using the Grafana Snowflake Datasource Plugin, if Oauth passthrough is enabled on the datasource, and multiple users are using the same datasource at the same time on a single Grafana instance, it could result in the wrong user identifier being used, and information for which the viewer is not authorized being returned. This issue affects Grafana Snowflake Datasource Plugin: from 1.5.0 before 1.14.1.
Affected products
- Grafana Labs Grafana Snowflake Datasource Plugin: from 1.5.0 before 1.14.1 — fixed in 1.14.1
How to fix
Upgrade to a fixed version: Grafana Labs Grafana Snowflake Datasource Plugin 1.14.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3717 or the next vulnerability affects your stack