What’s Vulnerable › Vulnerabilities
CVE-2025-3733: baguetteBox.js - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-034
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal baguetteBox.Js allows Cross-Site Scripting (XSS).This issue affects baguetteBox.Js: from 0.0.0 before 2.0.4, from 3.0.0 before 3.0.1.
Affected products
- Drupal baguetteBox.js: before 2.0.4; 3.0.0 — fixed in 2.0.4
How to fix
Upgrade to a fixed version: Drupal baguetteBox.js 2.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3733 or the next vulnerability affects your stack