What’s Vulnerable › Vulnerabilities
CVE-2025-3742: Responsive Lightbox & Gallery < 2.5.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Responsive Lightbox & Gallery WordPress plugin before 2.5.1 does not validate and escape some of its attributes before outputting them back in a page/post, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- dfactory Responsive Lightbox & Gallery: before 2.5.1 — fixed in 2.5.1
How to fix
Upgrade to a fixed version: dfactory Responsive Lightbox & Gallery 2.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3742 or the next vulnerability affects your stack