What’s Vulnerable › Vulnerabilities
CVE-2025-3744: Nomad Vulnerable To Violation Of Mandatory Sentinel Policies in Nomad Job Submissions via Policy Override
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-13 · updated 2026-06-17
- Weakness: CWE-266
Description
Nomad Enterprise (“Nomad”) jobs using the policy override option are bypassing the mandatory sentinel policies. This vulnerability, identified as CVE-2025-3744, is fixed in Nomad Enterprise 1.10.1, 1.9.9, and 1.8.13.
Affected products
- HashiCorp Nomad Enterprise: before 1.8.13; from 1.9.0 before 1.9.9; 1.10.0, 1.10.0-beta1, 1.10.0-rc1 — fixed in 1.8.13, 1.9.9
How to fix
Upgrade to a fixed version: HashiCorp Nomad Enterprise 1.8.13, 1.9.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3744 or the next vulnerability affects your stack