What’s Vulnerable › Vulnerabilities
CVE-2025-3757: Authentication Bypass in OpenPubKey
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-13 · updated 2026-06-17
- Weakness: CWE-305
Description
Versions of OpenPubkey library prior to 0.10.0 contained a vulnerability that would allow a specially crafted JWS to bypass signature verification.
Affected products
- Openpubkey: before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: Openpubkey 0.10.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3757 or the next vulnerability affects your stack