What’s Vulnerable › Vulnerabilities
CVE-2025-37727: Elasticsearch Insertion of sensitive information in log file
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-10 · updated 2026-10-08
- Weakness: CWE-532
Description
Insertion of sensitive information in log file in Elasticsearch can lead to loss of confidentiality under specific preconditions when auditing requests to the reindex API https://www.elastic.co/docs/api/doc/elasticsearch/operation/operation-reindex
Affected products
- Elasticsearch: from 7.0.0 through 7.17.29; from 8.0.0 before 8.18.8; from 8.19.0 before 8.19.5; from 9.0.0 before 9.0.8; from 9.1.0 before 9.1.5 — fixed in 8.18.8, 8.19.5, 9.0.8, 9.1.5
How to fix
Upgrade to a fixed version: Elasticsearch 8.18.8, 8.19.5, 9.0.8, 9.1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-37727 or the next vulnerability affects your stack