What’s Vulnerable › Vulnerabilities
CVE-2025-37730: Logstash Improper Certificate Validation in TCP output
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-06 · updated 2026-06-17
- Weakness: CWE-295
Description
Improper certificate validation in Logstash's TCP output could lead to a man-in-the-middle (MitM) attack in “client” mode, as hostname verification in TCP output was not being performed when the ssl_verification_mode => full was set.
Affected products
- Elastic Logstash: from 8.0.0 before 8.17.6; from 8.18.0 before 8.18.1; from 9.0.0 before 9.0.1 — fixed in 8.17.6, 8.18.1, 9.0.1
How to fix
Upgrade to a fixed version: Elastic Logstash 8.17.6, 8.18.1, 9.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-37730 or the next vulnerability affects your stack