What’s Vulnerable › Vulnerabilities
CVE-2025-37731: Elasticsearch Improper Authentication
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-15 · updated 2026-10-07
- Weakness: CWE-287
Description
Improper Authentication in Elasticsearch PKI realm can lead to user impersonation via specially crafted client certificates. A malicious actor would need to have such a crafted client certificate signed by a legitimate, trusted Certificate Authority.
Affected products
- Elasticsearch: from 7.0.0 through 7.17.29; from 8.0.0 before 8.19.8; from 9.0.0 before 9.1.8; from 9.2.0 before 9.2.2 — fixed in 8.19.8, 9.1.8, 9.2.2
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.8, 9.1.8, 9.2.2. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elasticsearch-8-19-8-9-1-8-and-9-2-2-security-update-esa-2025-27/384063
Get alerted when CVE-2025-37731 or the next vulnerability affects your stack