What’s Vulnerable › Vulnerabilities
CVE-2025-37732: Kibana Cross-site Scripting via the Integration Package Upload Functionality
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-15 · updated 2026-10-07
- Weakness: CWE-79
Description
Improper neutralization of input during web page generation ('Cross-site Scripting') (CWE-79) allows an authenticated user to render HTML tags within a user’s browser via the integration package upload functionality. This issue is related to ESA-2025-17 (CVE-2025-25018) bypassing that fix to achieve HTML injection.
Affected products
- Kibana: from 7.0.0 through 7.17.29; from 8.0.0 before 8.19.8; from 9.0.0 before 9.1.8; from 9.2.0 before 9.2.2 — fixed in 8.19.8, 9.1.8, 9.2.2
How to fix
Upgrade to a fixed version: Kibana 8.19.8, 9.1.8, 9.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-37732 or the next vulnerability affects your stack