What’s Vulnerable › Vulnerabilities
CVE-2025-37736: Elastic Cloud Enterprise Improper Authorization
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-07 · updated 2026-10-07
- Weakness: CWE-863
Description
Improper Authorization in Elastic Cloud Enterprise can lead to Privilege Escalation where the built-in readonly user can call APIs that should not be allowed. The list of APIs that are affected by this issue is: post:/platform/configuration/security/service-accounts delete:/platform/configuration/security/service-accounts/{user_id} patch:/platform/configuration/security/service-accounts/{user_id} post:/platform/configuration/security/service-accounts/{user_id}/keys delete:/platform/configuration/security/service-accounts/{user_id}/keys/{api_key_id} patch:/user post:/users post:/users/auth/keys delete:/users/auth/keys delete:/users/auth/keys/_all delete:/users/auth/keys/{api_key_id} delete:/users/{user_id}/auth/keys delete:/users/{user_id}/auth/keys/{api_key_id} delete:/users/{user_name} patch:/users/{user_name}
Affected products
- Elastic Cloud Enterprise: from 3.8.0 before 3.8.3; from 4.0.0 before 4.0.3 — fixed in 3.8.3, 4.0.3
How to fix
Upgrade to a fixed version: Elastic Cloud Enterprise 3.8.3, 4.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-37736 or the next vulnerability affects your stack