What’s Vulnerable › Vulnerabilities
CVE-2025-37746: perf/dwc_pcie: fix duplicate pci_dev devices
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-10-21
- Weakness: CWE-704
Description
In the Linux kernel, the following vulnerability has been resolved: perf/dwc_pcie: fix duplicate pci_dev devices During platform_device_register, wrongly using struct device pci_dev as platform_data caused a kmemdup copy of pci_dev. Worse still, accessing the duplicated device leads to list corruption as its mutex content (e.g., list, magic) remains the same as the original.
Affected products
- Linux kernel: from 6.8 before 6.14.3 — fixed in 6.14.3
How to fix
Upgrade to a fixed version: Linux kernel 6.14.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0778c3e01a9f382a5bc444a5271e013406642501
- https://git.kernel.org/stable/c/7f35b429802a8065aa61e2a3f567089649f4d98e
- https://git.kernel.org/stable/c/a71c6fc87b2b9905dc2e38887fe4122287216be9
Get alerted when CVE-2025-37746 or the next vulnerability affects your stack