What’s Vulnerable › Vulnerabilities
CVE-2025-37775: ksmbd: fix the warning from __kernel_write_iter
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix the warning from __kernel_write_iter [ 2110.972290] ------------[ cut here ]------------ [ 2110.972301] WARNING: CPU: 3 PID: 735 at fs/read_write.c:599 __kernel_write_iter+0x21b/0x280 This patch doesn't allow writing to directory.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.15 before 6.1.135; from 6.2 before 6.6.88; from 6.7 before 6.12.25; from 6.13 before 6.14.4; 6.15-rc1, 6.15-rc2 — fixed in 6.1.135, 6.12.25, 6.14.4, 6.6.88
How to fix
Upgrade to a fixed version: Linux kernel 6.1.135, 6.12.25, 6.14.4, 6.6.88. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1ed343481ba6911178bc5ca7a51be319eafcc747
- https://git.kernel.org/stable/c/2a879da5c34a1e5d971e815d5b30f27eb6d69efc
- https://git.kernel.org/stable/c/44079e544c9f6e3e9fb43a16ddf8b08cf686d657
- https://git.kernel.org/stable/c/b37f2f332b40ad1c27f18682a495850f2f04db0a
- https://git.kernel.org/stable/c/b7ce8db490286c2e009758fa1416d66aeb333614
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-37775 or the next vulnerability affects your stack