What’s Vulnerable › Vulnerabilities
CVE-2025-37776: ksmbd: fix use-after-free in smb_break_all_levII_oplock()
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-07-30
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix use-after-free in smb_break_all_levII_oplock() There is a room in smb_break_all_levII_oplock that can cause racy issues when unlocking in the middle of the loop. This patch use read lock to protect whole loop.
Affected products
- Linux kernel: from 5.15 before 6.6.88; from 6.7 before 6.12.25; from 6.13 before 6.14.4; 6.15-rc1, 6.15-rc2 — fixed in 6.12.25, 6.14.4, 6.6.88
How to fix
Upgrade to a fixed version: Linux kernel 6.12.25, 6.14.4, 6.6.88. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/18b4fac5ef17f77fed9417d22210ceafd6525fc7
- https://git.kernel.org/stable/c/296cb5457cc6f4a754c4ae29855f8a253d52bcc6
- https://git.kernel.org/stable/c/d54ab1520d43e95f9b2e22d7a05fc9614192e5a5
- https://git.kernel.org/stable/c/d73686367ad68534257cd88a36ca3c52cb8b81d8
Get alerted when CVE-2025-37776 or the next vulnerability affects your stack