What’s Vulnerable › Vulnerabilities
CVE-2025-37792: Bluetooth: btrtl: Prevent potential NULL dereference
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: Bluetooth: btrtl: Prevent potential NULL dereference The btrtl_initialize() function checks that rtl_load_file() either had an error or it loaded a zero length file. However, if it loaded a zero length file then the error code is not set correctly. It results in an error pointer vs NULL bug, followed by a NULL pointer dereference. This was detected by Smatch: drivers/bluetooth/btrtl.c:592 btrtl_initialize() warn: passing zero to 'ERR_PTR'
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.19 before 5.4.293; from 5.5 before 5.10.237; from 5.11 before 5.15.181; from 5.16 before 6.1.135; from 6.2 before 6.6.88; from 6.7 before 6.12.25 — fixed in 5.10.237, 5.15.181, 5.4.293, 6.1.135, 6.12.25, 6.14.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.237, 5.15.181, 5.4.293, 6.1.135. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2d7c60c2a38b4b461fa960ad0995136a6bfe0756
- https://git.kernel.org/stable/c/324dddea321078a6eeb535c2bff5257be74c9799
- https://git.kernel.org/stable/c/3db6605043b50c8bb768547b23e0222f67ceef3e
- https://git.kernel.org/stable/c/53ceef799dcfc22c734d600811bfc9dd32eaea0a
- https://git.kernel.org/stable/c/73dc99c0ea94abd22379b2d82cacbc73f3e18ec1
- https://git.kernel.org/stable/c/aaf356f872a60db1e96fb762a62c4607fd22741f
- https://git.kernel.org/stable/c/c3e9717276affe59fd8213706db021b493e81e34
- https://git.kernel.org/stable/c/d8441818690d795232331bd8358545c5c95b6b72
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-37792 or the next vulnerability affects your stack