What’s Vulnerable › Vulnerabilities
CVE-2025-37803: udmabuf: fix a buf size overflow issue during udmabuf creation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-06-17
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: udmabuf: fix a buf size overflow issue during udmabuf creation by casting size_limit_mb to u64 when calculate pglimit.
Affected products
- Linux kernel: before 5.4.293; from 5.5 before 5.10.237; from 5.11 before 5.15.181; from 5.16 before 6.1.136; from 6.2 before 6.6.89; from 6.7 before 6.14.5 — fixed in 5.10.237, 5.15.181, 5.4.293, 6.1.136, 6.14.5, 6.6.89
How to fix
Upgrade to a fixed version: Linux kernel 5.10.237, 5.15.181, 5.4.293, 6.1.136. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/021ba7f1babd029e714d13a6bf2571b08af96d0f
- https://git.kernel.org/stable/c/13fe12c037b470321436deec393030c6153cfeb9
- https://git.kernel.org/stable/c/29b65a3171a49c9b69f31035146be966cec40b7a
- https://git.kernel.org/stable/c/2b8419c6ecf69007dcff54ea0b9f0b215282c55a
- https://git.kernel.org/stable/c/373512760e13fdaa726faa9502d0f5be2abb3d33
- https://git.kernel.org/stable/c/3f6c9d66e0f8eb9679b57913aa64b4d2266f6fbe
- https://git.kernel.org/stable/c/b2ff4e9c599b000833d16a917f519aa2e4a75de2
- https://git.kernel.org/stable/c/e84a08fc7e25cdad5d9a3def42cc770ff711193f
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-37803 or the next vulnerability affects your stack