What’s Vulnerable › Vulnerabilities
CVE-2025-37810: usb: dwc3: gadget: check that event count does not exceed event buffer length
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: usb: dwc3: gadget: check that event count does not exceed event buffer length The event count is read from register DWC3_GEVNTCOUNT. There is a check for the count being zero, but not for exceeding the event buffer length. Check that event count does not exceed event buffer length, avoiding an out-of-bounds access when memcpy'ing the event. Crash log: Unable to handle kernel paging request at virtual address ffffffc0129be000 pc : __memcpy+0x114/0x180 lr : dwc3_check_event_buf+0xec/0x348 x3 : 0000000000000030 x2 : 000000000000dfc4 x1 : ffffffc0129be000 x0 : ffffff87aad60080 Call trace: __memcpy+0x114/0x180 dwc3_interrupt+0x24/0x34
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.2 before 5.4.293; from 5.5 before 5.10.237; from 5.11 before 5.15.181; from 5.16 before 6.1.136; from 6.2 before 6.6.89; from 6.7 before 6.12.26 — fixed in 5.10.237, 5.15.181, 5.4.293, 6.1.136, 6.12.26, 6.14.5
How to fix
Upgrade to a fixed version: Linux kernel 5.10.237, 5.15.181, 5.4.293, 6.1.136. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/015c39f38e69a491d2abd5e98869a500a9459b3b
- https://git.kernel.org/stable/c/52a7c9d930b95aa8b1620edaba4818040c32631f
- https://git.kernel.org/stable/c/63ccd26cd1f6600421795f6ca3e625076be06c9f
- https://git.kernel.org/stable/c/99d655119b870ee60e4dbf310aa9a1ed8d9ede3d
- https://git.kernel.org/stable/c/a44547015287a19001384fe94dbff84c92ce4ee1
- https://git.kernel.org/stable/c/b43225948b231b3f331194010f84512bee4d9f59
- https://git.kernel.org/stable/c/c0079630f268843a25ed75226169cba40e0d8880
- https://git.kernel.org/stable/c/c4d80e41cb42008dceb35e5dbf52574d93beac0d
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-37810 or the next vulnerability affects your stack