What’s Vulnerable › Vulnerabilities
CVE-2025-37819: irqchip/gic-v2m: Prevent use after free of gicv2m_get_fwnode()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: irqchip/gic-v2m: Prevent use after free of gicv2m_get_fwnode() With ACPI in place, gicv2m_get_fwnode() is registered with the pci subsystem as pci_msi_get_fwnode_cb(), which may get invoked at runtime during a PCI host bridge probe. But, the call back is wrongly marked as __init, causing it to be freed, while being registered with the PCI subsystem and could trigger: Unable to handle kernel paging request at virtual address ffff8000816c0400 gicv2m_get_fwnode+0x0/0x58 (P) pci_set_bus_msi_domain+0x74/0x88 pci_register_host_bridge+0x194/0x548 This is easily reproducible on a Juno board with ACPI boot. Retain the function for later use.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.5 before 5.4.294; from 5.5 before 5.10.238; from 5.11 before 5.15.182; from 5.16 before 6.1.138; from 6.2 before 6.6.89; from 6.7 before 6.12.26 — fixed in 5.10.238, 5.15.182, 5.4.294, 6.1.138, 6.12.26, 6.14.5
How to fix
Upgrade to a fixed version: Linux kernel 5.10.238, 5.15.182, 5.4.294, 6.1.138. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0c241dedc43a036599757cd08f356253fa3e5014
- https://git.kernel.org/stable/c/2f2803e4b5e4df2b08d378deaab78b1681ef9b30
- https://git.kernel.org/stable/c/3318dc299b072a0511d6dfd8367f3304fb6d9827
- https://git.kernel.org/stable/c/3939d6f29d34cdb60e3f68b76e39e00a964a1d51
- https://git.kernel.org/stable/c/47bee0081b483b077c7560bc5358ad101f89c8ef
- https://git.kernel.org/stable/c/b63de43af8d215b0499eac28b2caa4439183efc1
- https://git.kernel.org/stable/c/dc0d654eb4179b06d3206e4396d072108b9ba082
- https://git.kernel.org/stable/c/f95659affee301464f0d058d528d96b35b452da8
- https://lists.debian.org/debian-lts-announce/2025/08/msg00010.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
Get alerted when CVE-2025-37819 or the next vulnerability affects your stack