What’s Vulnerable › Vulnerabilities
CVE-2025-37823: net_sched: hfsc: Fix a potential UAF in hfsc_dequeue() too
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-10-15
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: net_sched: hfsc: Fix a potential UAF in hfsc_dequeue() too Similarly to the previous patch, we need to safe guard hfsc_dequeue() too. But for this one, we don't have a reliable reproducer.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 2.6.13 before 5.4.293; from 5.5 before 5.10.237; from 5.11 before 5.15.181; from 5.16 before 6.1.136; from 6.2 before 6.6.89; from 6.7 before 6.12.26 — fixed in 5.10.237, 5.15.181, 5.4.293, 6.1.136, 6.12.26, 6.14.5
How to fix
Upgrade to a fixed version: Linux kernel 5.10.237, 5.15.181, 5.4.293, 6.1.136. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/11bccb054c1462fb069219f8e98e97a5a730758e
- https://git.kernel.org/stable/c/2f46d14919c39528c6e540ebc43f90055993eedc
- https://git.kernel.org/stable/c/68f256305ceb426d545a0dc31f83c2ab1d211a1e
- https://git.kernel.org/stable/c/6ccbda44e2cc3d26fd22af54c650d6d5d801addf
- https://git.kernel.org/stable/c/76c4c22c2437d3d3880efc0f62eca06ef078d290
- https://git.kernel.org/stable/c/c6936266f8bf98a53f28ef9a820e6a501e946d09
- https://git.kernel.org/stable/c/c6f035044104c6ff656f4565cd22938dc892528c
- https://git.kernel.org/stable/c/da7936518996d290e2fcfcaf6cd7e15bfd87804a
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-37823 or the next vulnerability affects your stack