What’s Vulnerable › Vulnerabilities
CVE-2025-37839: jbd2: remove wrong sb->s_sequence check
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-09 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: jbd2: remove wrong sb->s_sequence check Journal emptiness is not determined by sb->s_sequence == 0 but rather by sb->s_start == 0 (which is set a few lines above). Furthermore 0 is a valid transaction ID so the check can spuriously trigger. Remove the invalid WARN_ON.
Affected products
- Debian Linux: 11.0
- Linux kernel: before 5.4.293; from 5.5 before 5.10.237; from 5.11 before 5.15.181; from 5.16 before 6.1.135; from 6.2 before 6.6.88; from 6.7 before 6.12.24 — fixed in 5.10.237, 5.15.181, 5.4.293, 6.1.135, 6.12.24, 6.13.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.237, 5.15.181, 5.4.293, 6.1.135. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3b4643ffaf72d7a5a357e9bf68b1775f8cfe7e77
- https://git.kernel.org/stable/c/9eaec071f111cd2124ce9a5b93536d3f6837d457
- https://git.kernel.org/stable/c/ad926f735b4d4f10768fec7d080cadeb6d075cac
- https://git.kernel.org/stable/c/b0cca357f85beb6144ab60c62dcc98508cc044bf
- https://git.kernel.org/stable/c/b479839525fe7906966cdc4b5b2afbca048558a1
- https://git.kernel.org/stable/c/c88f7328bb0fff66520fc9164f02b1d06e083c1b
- https://git.kernel.org/stable/c/c98eb9ffb1d9c98237b5e1668eee17654e129fb0
- https://git.kernel.org/stable/c/cf30432f5b3064ff85d85639c2f0106f89c566f6
- https://git.kernel.org/stable/c/e6eff39dd0fe4190c6146069cc16d160e71d1148
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-37839 or the next vulnerability affects your stack