What’s Vulnerable › Vulnerabilities
CVE-2025-37842: spi: fsl-qspi: use devm function instead of driver remove
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-09 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: spi: fsl-qspi: use devm function instead of driver remove Driver use devm APIs to manage clk/irq/resources and register the spi controller, but the legacy remove function will be called first during device detach and trigger kernel panic. Drop the remove function and use devm_add_action_or_reset() for driver cleanup to ensure the release sequence. Trigger kernel panic on i.MX8MQ by echo 30bb0000.spi >/sys/bus/platform/drivers/fsl-quadspi/unbind
Affected products
- Linux kernel: from 5.2 before 6.6.105; from 6.7 before 6.12.36; from 6.13 before 6.13.12; from 6.14 before 6.14.3 — fixed in 6.6.105, 6.12.36, 6.13.12, 6.14.3
- Linux: 5.2 — fixed in 6.15
How to fix
Upgrade to a fixed version: Linux kernel 6.6.105, 6.12.36, 6.13.12, 6.14.3; Linux 6.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/40369bfe717e96e26650eeecfa5a6363563df6e4
- https://git.kernel.org/stable/c/439688dbe82baa10d4430dc3252bb5ef1183a171
- https://git.kernel.org/stable/c/50ae352c1848cab408fb4f7d7f50c71f818bbdbf
- https://git.kernel.org/stable/c/69d2d7020b9966817ffc7442ae778c29cb81813f
- https://git.kernel.org/stable/c/f68b27d82a749117d9c7d7f33fa53f46373e38e2
- https://git.kernel.org/stable/c/f9bfb3a5f6f616f3eb7665c8ff3bcb9760ae33c8
Get alerted when CVE-2025-37842 or the next vulnerability affects your stack