What’s Vulnerable › Vulnerabilities
CVE-2025-37851: fbdev: omapfb: Add 'plane' value check
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-09 · updated 2026-06-17
- Weakness: CWE-674
Description
In the Linux kernel, the following vulnerability has been resolved: fbdev: omapfb: Add 'plane' value check Function dispc_ovl_setup is not intended to work with the value OMAP_DSS_WB of the enum parameter plane. The value of this parameter is initialized in dss_init_overlays and in the current state of the code it cannot take this value so it's not a real problem. For the purposes of defensive coding it wouldn't be superfluous to check the parameter value, because some functions down the call stack process this value correctly and some not. For example, in dispc_ovl_setup_global_alpha it may lead to buffer overflow. Add check for this value. Found by Linux Verification Center (linuxtesting.org) with SVACE static analysis tool.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 2.6.33 before 5.4.293; from 5.5 before 5.10.237; from 5.11 before 5.15.181; from 5.16 before 6.1.135; from 6.2 before 6.6.88; from 6.7 before 6.12.24 — fixed in 5.10.237, 5.15.181, 5.4.293, 6.1.135, 6.12.24, 6.13.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.237, 5.15.181, 5.4.293, 6.1.135. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/09dbf22fd68c2f1a81ab89670ffa1ec3033436c4
- https://git.kernel.org/stable/c/3e411827f31db7f938a30a3c7a7599839401ec30
- https://git.kernel.org/stable/c/4efd8ef5e40f2c7a4a91a5a9f03140bfa827da89
- https://git.kernel.org/stable/c/52eafaa56f8f6d6a0cdff9282b25b4acbde34edc
- https://git.kernel.org/stable/c/660a53a0694d1f3789802509fe729dd4656fc5e0
- https://git.kernel.org/stable/c/9b0a41589ee70529b20e1e0108d03f10c649bdc4
- https://git.kernel.org/stable/c/a570efb4d877adbf3db2dc95487f2ba6bfdd148a
- https://git.kernel.org/stable/c/cdf41d72e8b015d9ea68f5a1c0a79624e7c312aa
- https://git.kernel.org/stable/c/fda15c5b96b883d62fb2d84a3a1422aa87717897
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-37851 or the next vulnerability affects your stack