What’s Vulnerable › Vulnerabilities
CVE-2025-37857: scsi: st: Fix array overflow in st_setup()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-09 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: st: Fix array overflow in st_setup() Change the array size to follow parms size instead of a fixed value.
Affected products
- Debian Linux: 11.0
- Linux kernel: before 5.4.293; from 5.5 before 5.10.237; from 5.11 before 5.15.181; from 5.16 before 6.1.135; from 6.2 before 6.6.88; from 6.7 before 6.12.24 — fixed in 5.10.237, 5.15.181, 5.4.293, 6.1.135, 6.12.24, 6.13.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.237, 5.15.181, 5.4.293, 6.1.135. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/574b399a7fb6ae71c97e26d122205c4a720c0e43
- https://git.kernel.org/stable/c/736ae988bfb5932c05625baff70fba224d547c08
- https://git.kernel.org/stable/c/7fe3b4deed8b93609058c37c9a11df1d2b2c0423
- https://git.kernel.org/stable/c/a018d1cf990d0c339fe0e29b762ea5dc10567d67
- https://git.kernel.org/stable/c/ad4c3037dc77739a625246a2a0fb23b8f3402c06
- https://git.kernel.org/stable/c/c6015d0f7a2236ddb3928b2dfcb1c556a1368b55
- https://git.kernel.org/stable/c/e4d1ca0a84a6650d3172eb8c07ef2fbc585b0d96
- https://git.kernel.org/stable/c/e6b585d016c47ca8a37b92ea8a3fe35c0b585256
- https://git.kernel.org/stable/c/f746fe0c51e044d1248dc67918328bfb3d86b639
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-37857 or the next vulnerability affects your stack