What’s Vulnerable › Vulnerabilities
CVE-2025-37863: ovl: don't allow datadir only
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-09 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ovl: don't allow datadir only In theory overlayfs could support upper layer directly referring to a data layer, but there's no current use case for this. Originally, when data-only layers were introduced, this wasn't allowed, only introduced by the "datadir+" feature, but without actually handling this case, resulting in an Oops. Fix by disallowing datadir without lowerdir.
Affected products
- Linux kernel: from 6.6.23 before 6.6.88; from 6.7 before 6.12.25; from 6.13 before 6.14.4; 6.15-rc1, 6.15-rc2 — fixed in 6.12.25, 6.14.4, 6.6.88
How to fix
Upgrade to a fixed version: Linux kernel 6.12.25, 6.14.4, 6.6.88. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0874b629f65320778e7e3e206177770666d9db18
- https://git.kernel.org/stable/c/21d2ffb0e9838a175064c22f3a9de97d1f56f27d
- https://git.kernel.org/stable/c/b9e3579213ba648fa23f780e8d53e99011c62331
- https://git.kernel.org/stable/c/eb3a04a8516ee9b5174379306f94279fc90424c4
Get alerted when CVE-2025-37863 or the next vulnerability affects your stack