What’s Vulnerable › Vulnerabilities
CVE-2025-37909: net: lan743x: Fix memleak issue when GSO enabled
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-10-15
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: net: lan743x: Fix memleak issue when GSO enabled Always map the `skb` to the LS descriptor. Previously skb was mapped to EXT descriptor when the number of fragments is zero with GSO enabled. Mapping the skb to EXT descriptor prevents it from being freed, leading to a memory leak
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.17 before 5.4.294; from 5.5 before 5.10.238; from 5.11 before 5.15.182; from 5.16 before 6.1.138; from 6.2 before 6.6.90; from 6.7 before 6.12.28 — fixed in 5.10.238, 5.15.182, 5.4.294, 6.1.138, 6.12.28, 6.14.6
How to fix
Upgrade to a fixed version: Linux kernel 5.10.238, 5.15.182, 5.4.294, 6.1.138. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/093855ce90177488eac772de4eefbb909033ce5f
- https://git.kernel.org/stable/c/189b05f189cac9fd233ef04d31cb5078c4d09c39
- https://git.kernel.org/stable/c/2d52e2e38b85c8b7bc00dca55c2499f46f8c8198
- https://git.kernel.org/stable/c/6c65ee5ad632eb8dcd3a91cf5dc99b22535f44d9
- https://git.kernel.org/stable/c/a0e0efbabbbe6a1859bc31bf65237ce91e124b9b
- https://git.kernel.org/stable/c/dae1ce27ceaea7e1522025b15252e3cc52802622
- https://git.kernel.org/stable/c/df993daa4c968b4b23078eacc248f6502ede8664
- https://git.kernel.org/stable/c/f42c18e2f14c1b1fdd2a5250069a84bc854c398c
- https://lists.debian.org/debian-lts-announce/2025/08/msg00010.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2025-37909 or the next vulnerability affects your stack