What’s Vulnerable › Vulnerabilities
CVE-2025-37940: ftrace: Add cond_resched() to ftrace_graph_set_hash()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-06-17
- Weakness: CWE-667
Description
In the Linux kernel, the following vulnerability has been resolved: ftrace: Add cond_resched() to ftrace_graph_set_hash() When the kernel contains a large number of functions that can be traced, the loop in ftrace_graph_set_hash() may take a lot of time to execute. This may trigger the softlockup watchdog. Add cond_resched() within the loop to allow the kernel to remain responsive even when processing a large number of functions. This matches the cond_resched() that is used in other locations of the code that iterates over all functions that can be traced.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.11 before 5.4.293; from 5.5 before 5.10.237; from 5.11 before 5.15.181; from 5.16 before 6.1.135; from 6.2 before 6.6.88; from 6.7 before 6.12.24 — fixed in 5.10.237, 5.15.181, 5.4.293, 6.1.135, 6.12.24, 6.13.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.237, 5.15.181, 5.4.293, 6.1.135. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1fce9574b9d515bcb8a75379a8053e18602424e3
- https://git.kernel.org/stable/c/42ea22e754ba4f2b86f8760ca27f6f71da2d982c
- https://git.kernel.org/stable/c/4429535acab750d963fdc3dfcc9e0eee42f4d599
- https://git.kernel.org/stable/c/5d336ac215e5c76e43ef4bca9ba699835e53e2fd
- https://git.kernel.org/stable/c/618655d54c5f8af5d57b77491d08c0f0ff77d114
- https://git.kernel.org/stable/c/72be43ff061a889c6ee648a330a42486cafa15a6
- https://git.kernel.org/stable/c/8dd7d7280357596ba63dfdb4c1725d9dd24bd42a
- https://git.kernel.org/stable/c/dd38803c9088b848c6b56f4f6d7efc4497bfde61
- https://git.kernel.org/stable/c/e5b4ae6f01d4a510d5725eca7254519a1093920d
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-37940 or the next vulnerability affects your stack