What’s Vulnerable › Vulnerabilities
CVE-2025-37947: ksmbd: prevent out-of-bounds stream writes by validating *pos
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-07-30
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: prevent out-of-bounds stream writes by validating *pos ksmbd_vfs_stream_write() did not validate whether the write offset (*pos) was within the bounds of the existing stream data length (v_len). If *pos was greater than or equal to v_len, this could lead to an out-of-bounds memory write. This patch adds a check to ensure *pos is less than v_len before proceeding. If the condition fails, -EINVAL is returned.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.15 before 6.1.139; from 6.2 before 6.6.91; from 6.7 before 6.12.29; from 6.13 before 6.14.7; 6.15-rc1, 6.15-rc2, 6.15-rc3, 6.15-rc4, 6.15-rc5 — fixed in 6.1.139, 6.12.29, 6.14.7, 6.6.91
How to fix
Upgrade to a fixed version: Linux kernel 6.1.139, 6.12.29, 6.14.7, 6.6.91. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/04c8a38c60346bb5a7c49b276de7233f703ce9cb
- https://git.kernel.org/stable/c/0ca6df4f40cf4c32487944aaf48319cb6c25accc
- https://git.kernel.org/stable/c/7f61da79df86fd140c7768e668ad846bfa7ec8e1
- https://git.kernel.org/stable/c/d62ba16563a86aae052f96d270b3b6f78fca154c
- https://git.kernel.org/stable/c/e6356499fd216ed6343ae0363f4c9303f02c5034
- https://lists.debian.org/debian-lts-announce/2025/08/msg00010.html
- https://github.com/doyensec/KSMBD-CVE-2025-37947/blob/main/CVE-2025-37947.c
Get alerted when CVE-2025-37947 or the next vulnerability affects your stack