What’s Vulnerable › Vulnerabilities
CVE-2025-37963: arm64: bpf: Only mitigate cBPF programs loaded by unprivileged users
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: arm64: bpf: Only mitigate cBPF programs loaded by unprivileged users Support for eBPF programs loaded by unprivileged users is typically disabled. This means only cBPF programs need to be mitigated for BHB. In addition, only mitigate cBPF programs that were loaded by an unprivileged user. Privileged users can also load the same program via eBPF, making the mitigation pointless.
Affected products
- Debian Linux: 11.0
- Linux kernel: before 5.10.239; from 5.11 before 5.15.186; from 5.16 before 6.1.139; from 6.2 before 6.6.91; from 6.7 before 6.12.29; from 6.13 before 6.14.7 — fixed in 5.10.239, 5.15.186, 6.1.139, 6.12.29, 6.14.7, 6.6.91
How to fix
Upgrade to a fixed version: Linux kernel 5.10.239, 5.15.186, 6.1.139, 6.12.29. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/038866e01ea5e5a3d948898ac216e531e7848669
- https://git.kernel.org/stable/c/477481c4348268136227348984b6699d6370b685
- https://git.kernel.org/stable/c/6e52d043f7dbf1839a24a3fab2b12b0d3839de7a
- https://git.kernel.org/stable/c/80251f62028f1ab2e09be5ca3123f84e8b00389a
- https://git.kernel.org/stable/c/df53d418709205450a02bb4d71cbfb4ff86f2c1e
- https://git.kernel.org/stable/c/e5f5100f1c64ac6c72671b2cf6b46542fce93706
- https://git.kernel.org/stable/c/f300769ead032513a68e4a02e806393402e626f8
- https://lists.debian.org/debian-lts-announce/2025/08/msg00010.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
Get alerted when CVE-2025-37963 or the next vulnerability affects your stack