What’s Vulnerable › Vulnerabilities
CVE-2025-37969: iio: imu: st_lsm6dsx: fix possible lockup in st_lsm6dsx_read_tagged_fifo
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-06-17
- Weakness: CWE-667
Description
In the Linux kernel, the following vulnerability has been resolved: iio: imu: st_lsm6dsx: fix possible lockup in st_lsm6dsx_read_tagged_fifo Prevent st_lsm6dsx_read_tagged_fifo from falling in an infinite loop in case pattern_len is equal to zero and the device FIFO is not empty.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.20 before 5.4.294; from 5.5 before 5.10.238; from 5.11 before 5.15.183; from 5.16 before 6.1.139; from 6.2 before 6.6.91; from 6.7 before 6.12.29 — fixed in 5.10.238, 5.15.183, 5.4.294, 6.1.139, 6.12.29, 6.14.7
How to fix
Upgrade to a fixed version: Linux kernel 5.10.238, 5.15.183, 5.4.294, 6.1.139. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/16857370b3a30663515956b3bd27f3def6a2cf06
- https://git.kernel.org/stable/c/35b8c0a284983b71d92d082c54b7eb655ed4194f
- https://git.kernel.org/stable/c/4db7d923a8c298788181b796f71adf6ca499f966
- https://git.kernel.org/stable/c/76727a1d81afde77d21ea8feaeb12d34605be6f4
- https://git.kernel.org/stable/c/8114ef86e2058e2554111b793596f17bee23fa15
- https://git.kernel.org/stable/c/9ce662851380fe2018e36e15c0bdcb1ad177ed95
- https://git.kernel.org/stable/c/9ddb4cf2192c213e4dba1733bbcdc94cf6d85bf7
- https://git.kernel.org/stable/c/dadf9116108315f2eb14c7415c7805f392c476b4
- https://lists.debian.org/debian-lts-announce/2025/08/msg00010.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
Get alerted when CVE-2025-37969 or the next vulnerability affects your stack